Nortel Avaya LACP Error

Rate-Limiting error with LACP

There is a very misleading error message in the Nortel / Avaya Enterprise Routing Switches. It occurs when you try to configure LACP  / 802.3ad.

Error message

This stupid error:

"ports have bad rate limiting config"

4526GTX(config-if)#lacp mode port 1/25-26,2/25-26 active
% Cannot modify settings
% Ports have bad rate limiting config

 

 

Meaning

You need to chose a different aggregator key for this. The switch doesn't auto assign the keys on ports for enabling active LACP.

4526GTX(config-if)#lacp ?
Configure LACP port parameters
  aggregation   Enable port aggregation mode
  clear-stats   Clear LACP statistics
  key           Set key value for ports
  mode          Set LACP port mode
  priority      Set port priority
  timeout-time  Set port timeout

4526GTX(config-if)#lacp key ?
  <1-4095>  Key value
  port      Specify port list
4526GTX(config-if)#lacp key 2327
4526GTX(config-if)#lacp aggregation ?
  enable  Enable port aggregation mode
  port    Specify port list
4526GTX(config-if)#lacp aggregation enable

 

 

Finally, don't forget to optimize the failure detection and failover times. To achieve a 1-3 second failover, set the LACP fast rate using:

4526GTX(config-if)#interface fastEthernet 1/25-26
4526GTX(config-if)#la
4526GTX(config-if)#lacp ?
Configure LACP port parameters
  aggregation   Enable port aggregation mode
  clear-stats   Clear LACP statistics
  key           Set key value for ports
  mode          Set LACP port mode
  priority      Set port priority
  timeout-time  Set port timeout

4526GTX(config-if)#lacp timeout-time ?
  long   long timeout time
  port   Specify port list
  short  short timeout time
4526GTX(config-if)#lacp timeout-time short

 

 

No VLAN error with LACP

 

This error can occur while you configure a LACP trunk

4526GTX(config-if)#lacp key 1234
4526GTX(config-if)#lacp mode active
% Cannot modify settings
% Ports do not belong to a vlan

 

 

Showing the running config made me find that "my" ports 4/45-46 were in fact not in the desired VLAN and had a old, wrong PVID

vlan members 1 1/13-23,1/25-26,2/1-24,2/46-48,3/1-48,4/1-44,4/47-48,5/1-48,6/1-
48
...
vlan ports 2/47-48,3/45-48,4/45-46,5/45-48,6/45-46 pvid 10

 

 

I had to:

  • disable LACP
  • reset the port to untagged
  • put it back in the desired VLAN

 

4526GTX(config)#interface fastEthernet 4/45-46
4526GTX(config-if)#no lacp aggregation enable
4526GTX(config-if)#exit
4526GTX(config)#vlan ports 4/45-46 tagging disable
4526GTX(config)#vlan members add 1 4/45-46
4526GTX(config)#interface fastEthernet 4/45-46
4526GTX(config-if)#lacp aggregation enable
4526GTX(config-if)#lacp mode active
4526GTX(config-if)#lacp timeout-time short

 

 

Same port key is used by ports belonging to different VLAN

alle vlans abgleichen


LACP trunks not working

I have ended up with a scenario where the LACP links, after a reconfiguration, were still showing PDUs in show lacp debug, but were no longer listed in show mlt

https://forums.networkinfrastructure.info/nortel-ethernet-switching/no-lacp-id-on-links-but-pdus-being-exchanged/

Solution was to set the lacp key once more.